Subscribe for automatic updates: RSS icon RSS

Login icon Sign in for full access | Help icon Help
Advanced search

Pages: [1]
  Reply  |  Print  
Author Topic: Studio new install Welcome Page and Help Text show blank window  (Read 6199 times)
Jonathan B.
Posts: 3


« on: July 07, 2020, 12:04:27 am »

Hello,

Had an equipment failure and reinstalled Genero Studio 3.20.08 with all recent updates.  The Welcome back is now blank as well as the actual verbiage in the help utility
It looks like the HTML render is not hooked correctly. 
I have looked all over but the fix is not obvious.
Any help on how to fix this appreciated
Windows 10 Laptop
Reuben B.
Four Js
Posts: 830


« Reply #1 on: July 09, 2020, 02:08:13 am »

If you have not already I would suggest contacting your local support contact.

If it is "HTML render is not hooked correctly" there are some environment variables you can use, particularly if you have an old graphics driver, although the symptoms for that you still see something ,just in the wrong scale, so I don't think that is necessarily the issue.

My suspicion is that there maybe something beneath APPDATA (permissions, partial install, corruption that type of thing) and it is a case of deleting a particular directory so that Studio thinks it is being used for the first time after an install.

Product Consultant (Asia Pacific)
Developer Relations Manager (Worldwide)
Author of https://4js.com/ask-reuben
Contributor to https://github.com/FourjsGenero
Nuno G.
Posts: 14


« Reply #2 on: July 09, 2020, 12:28:09 pm »

Hi Reuben.
I do believe I stunled on the same issue long time ago but up to this moment I got no solution.
In my case the problem appeared when I installed a new version off the 3.10.* on a different directory of the previous version without uninstall the older version first.
Since then I have to go online to read the documentation since no solution has been found.
HIH
Nuno G.
Posts: 14


« Reply #3 on: July 09, 2020, 12:30:18 pm »

Sorry! .. stumbled...
Scott B.
Four Js
Posts: 23


« Reply #4 on: July 15, 2020, 05:16:17 pm »

To fix this issue, try the following:

Navigate to the AppData directory that stores the documentation set used by GST. This is a copy that is made when GST HELP is first brought up.

On my system, I find this in my AppData\Local folder like you see here: C:\Users\sbarney\AppData\Local\FourJs\Genero Studio Documentation 3.20.08-33781

If you delete the help folder found here for your current version, it should recreate it when you next start GST and bring up Help.

Let us know if this fixes the issue for you.
Nuno G.
Posts: 14


« Reply #5 on: July 15, 2020, 06:00:12 pm »

Thank you Scott! It worked perfectly.
Nuno
Laurent G.
Four Js
Posts: 94


« Reply #6 on: July 15, 2020, 07:46:55 pm »

Hi,

Quick additional update:

As our local support further investigated with Jonathan, it was determined that the blank Windows were not only white but also "black rectangles" and that the problem wasn't GST only but also GDC. So that lead us to suspect some QT graphics related issue/bug that can be helped by setting some specific environment variables.

It was then confirmed that the following setting worked:

QT_QUICK_BACKEND=software which is a software renderer backend, with no shader support

As stated above, those type of issues are usually linked to older graphics card drivers or HW not compatible with the latest QT libraries -- upgrading HW is more than often not the answer ...

We hope this info will be useful to anybody in our community experiencing related rendering/scaling problems. Note also that there are other QT settings that can possibly help, contact your local support if needed.

Best,

Laurent
Pages: [1]
  Reply  |  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines