Subscribe for automatic updates: RSS icon RSS

Login icon Sign in for full access | Help icon Help
Advanced search

Pages: [1]
  Reply  |  Print  
Author Topic: GAS 3.00 Startup with "-s" argument  (Read 4929 times)
Najmi N.
Posts: 14


« on: March 03, 2017, 04:25:07 am »

Hi

The GAS was setup to be behind Apache Webserver. Logically it was not standalone.

But I just wondering why I have to use "-s" argument where -s mean standalone everytime I startup the GAS in order  for the Apache to connect with GAS application.
If I startup without "-s" I couldnt open the application menu and the apache error_log will have below error message :-

Thu Mar 02 10:41:31.383913 2017] [fastcgi:error] [pid 12189:tid 139752899270400] (111)Connection refused: [client 192.168.4.90:64233] FastCGI: failed to connect to server "/gas-as4": connect() failed


Appreciat expert advise.
Sisavanh S.
Four Js
Posts: 67


« Reply #1 on: March 03, 2017, 03:01:06 pm »

Hi,

In this case standalone means GAS started manually (option -s) and not started automatically by Apache (see $FGLASDIR/bin/wrapper.fcgi)
There is a slight difference in the protocol, so make sure you start the GAS with the correct options.

Best regards,
Sisa.
Pages: [1]
  Reply  |  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines